Cart overview
Your cart is empty
Total (including VAT)
Close CartCheckout >>

Support & Downloads

Being an Elektron user means being cared for.

Resources for Overbridge

Downloads

  • Overbridge 1.15 for Windows
    Overbridge 1.15 adds support for Analog Heat. There's a ton of more improvements and fixes, under or over the hood.

    It is important to notice that Overbridge 1.15 requires OS upgrades for all the machines. It is not possible to use OB 1.15 with previous (public) Elektron OS:es, and it is also not possible to use the new Elektron OS:es with Overbridge 1.10.x installations!

    Download Release notes

  • Overbridge 1.15 for Mac OS X
    Overbridge 1.15 adds support for Analog Heat, and on top of that it's now macOS Sierra compatible as well. There's a ton of more improvements and fixes, under or over the hood.

    It is important to notice that Overbridge 1.15 requires OS upgrades for all the machines. It is not possible to use OB 1.15 with previous (public) Elektron OS:es, and it is also not possible to use the new Elektron OS:es with Overbridge 1.10.x installations!

    Download Release notes

Manuals

  • Overbridge 1.15 User Manual (English)
    This manual covers the basics of installing, setting up and using the Overbridge software suite (1.15).

    Download

  • Overbridge 1.10 User Manual (Japanese)
    This manual covers the basics of installing, setting up and using the Overbridge software suite (1.10).

    Download

FAQ

  • Can I use my external soundcard while using Overbridge?
  • I am having issues on my Mac with Intel Xeon/Core2Duo processor
  • I have a feature request
  • I have a problem, how do I get support?
  • Is it possible to send MIDI from my Analog device to Overbridge?
  • Is there a way to have more than a total of 10 channels via Overbridge?
  • My latency is very high
  • System requirements
  • Under what circumstances do I need to use a USB hub with Overbridge?
  • What does Total Recall mean?
  • Which machines are Overbridge enabled?
  • Will Overbridge be compatible with Mac OS 10.6 / Windows Vista or lower?

Contact support

  • If you can't find what you are looking for, you may login with your Elektron account and create a support ticket. If you don't have an account already you can create one in the next step.

    Create a ticket